Remote-query timing out |

You are here

Remote-query timing out

6 posts / 0 new
Last post
Remote-query timing out

I'm having some problems getting remote-query working on a ubr7246. I've got the cmts set to use remote-query, and I'm sure I'm using the right community as I can poll the modems via other snmp utilities. The subnet allowed to access snmp defined in the modem includes the remote-query src ip that I'm using.

Debugging snmp on the CMTS yields:

5d22h: v1 packet
5d22h: community string: cm_client_skinner
For IP address
SNMP proxy exec got event,but queue is empty

'show snmp sessions' says:

Destination:, V1 community: cm_client_skinner, Expires in 545 secs
Round-trip-times: 0/0/0 (min/max/last)
packets output
3 Gets, 0 GetNexts, 0 GetBulks, 0 Sets, 0 Informs
3 Timeouts, 0 Drops
packets input
0 Traps, 0 Informs, 0 Responses (0 errors)

CMTS# show snmp
239119 SNMP packets input
0 Bad SNMP version errors
99 Unknown community name
0 Illegal operation for community name supplied
10 Encoding errors
208338 Number of requested variables
0 Number of altered variables
140657 Get-request PDUs
98353 Get-next PDUs
0 Set-request PDUs
0 Input queue packet drops (Maximum queue size 1000)
260765 SNMP packets output
0 Too big errors (Maximum packet size 1500)
30672 No such name errors
0 Bad values errors
0 General errors
239010 Response PDUs
0 Trap PDUs

SNMP logging: disabled

SNMP Manager-role output packets
21755 Get-request PDUs
0 Get-next PDUs
0 Get-bulk PDUs
0 Set-request PDUs
0 Inform-request PDUs
21754 Timeouts
0 Drops
SNMP Manager-role input packets
0 Inform request PDUs
0 Trap PDUs
0 Response PDUs
0 Responses with errors

SNMP informs: disabled

I see there's a lot of 'No such name errors', which I believe means that the OID requested by the CMTS doesn't exist on the modem. I am using Motorola surfboard modems. The MIB used for remote-query isn't Cisco proprietary is it? Any ideas why it's not working?

I don't remember the full

I don't remember the full story behind it, but I know there is a gotcha with this !

Not sure now if the gotcha relates to the hardware platform, or the IOS version but here's the back story :

Years ago when we had 7246VXR and DOCSIS 2.0 we used the same community to poll the CMTS, and for the CMTS to remote-query the modems.


cable modem remote-query 10 MYCOMMUNITY
cable modem remote-query src-ip x.x.x.x
snmp-server community MYCOMMUNITY RO 70

When we upgraded to ubr10K (and we probably changed from 12.3 to 12.2SC IOS at the same time), from memory we found that you could not use the same community for these two tasks. They have to be different. eg :

cable modem remote-query 10 MYCOMMUNITY
cable modem remote-query src-ip x.x.x.x
snmp-server community MYOTHERCOMMUNITY RO 70

Perhaps give that a try!

Some other random thoughts :

* I just remembered there was a bug in the early 12.2SC trains where the "remote-query source-ip" was not working. The bundle IP was being used instead. It was fixed in SCD6. So if you have an IOS older than this you should try upgrading.

* There is a hidden IOS command which you can use for a bit of testing from the CMTS CLI :

snmp get v1 y.y.y.y MYCOMMUNITY oid ifNumber.0

this can be handy to when trying to work out ACLS etc are blocking your queries

* in my example above, the SNMP engine has access-list 70 attached. In this list you need to ensure you have permitted the CM IP ranges, otherwise remote-query wont work

I tried not defining the CM

I tried not defining the CM community in 'snmp-server community...' without success. Though I seem to remember reading somewhere in the cisco docs that it needed to be defined in the cmts in some IOS versions?

I'm running 12.3(17a)BC, so I shouldn't be seeing that bug if that's correct. But I explicitly allowed the default bundle IP in the CM config file.

Blast cisco and their hidden commands! I tried the snmp get command, and got:

CMTS# snmp get v1 COMMUNITY oid ifNumber.0
unable to build oid

Not sure exactly what that means, maybe that's related to the failure? I could try a different IOS version. I tried requesting . with the same output. Any other ideas?

I did a quick google to try

I did a quick google to try and suss out more info on the "snmp get" syntax

This link appears to give some more clues


#snmp get v1 MyCommunity oid ifNumber.0
SNMP Response: reqid 209130029, errstat 0, erridx 0
ifNumber.0 = 13

#snmp get v1 MyCommunity oid
SNMP Response: reqid 209129886, errstat 0, erridx 0
ifNumber.0 = 13

Yea, I read that doc and

Yea, I read that doc and tried several different commands, but I always get "unable to build oid." I'm going to try a different IOS version....

Just a thought, we had issues

Just a thought, we had issues with remote-query on our ubr7246 as well and eventually we realised we had forgotten about allowing the cmts to poll the modems in the modems config files. After adjusting our config files remote-query worked flawless.

We also use Motorola modems on our ubr7246 btw with release 12.3(17b)BC8.

Log in or register to post comments