Is docsis_server a dead project ? |

You are here

Is docsis_server a dead project ?

23 posts / 0 new
Last post
Is docsis_server a dead project ?

I would like to know if I can still use docsis_server or the project is dead ?

Is it safe to use and/or can a server running it be updated without breaking docsis_server ?

Is there anyone that eventually can help with installation ?


:-) Jens

I don't think its dead. I

I don't think its dead. I still use it quite a bit in lab, and until recently, used it for multiple smaller operators as well.


You may have to hand edit a few of the config scripts in order to get it to install on a newer operating system just from the items it self checks for responding differently than they used to. That is what I ran into installing it.

However I have had awful luck getting it to work at all with DOCSIS 3 CMTS and Modems combos, and with very little people left to try and work with on troubleshooting the project it fairly dead to me. That is something to keep in mind if you production it.

I have launched multiple

I have launched multiple DOCSIS3 systems on it.

The hard part is EMTAs, but DOCSIS3 is just a normal DOCSIS1.1 QOS file.

Edit: There was one change I had to make. Newer modems (I think I first saw it on SB5101s), would crash the DHCP portion of the program.

Would have to go into the C file, and just increase size of the variable for, I believe, modem capabilities.



the github-project is not dead and everybody is welcome to support it.
if you have issues/bugs/changes feel free to report them.


the github-project is not

the github-project is not dead and everybody is welcome to support it.
if you have issues/bugs/changes feel free to report them.

I need to know if I can use it with a new system (Debian Wheezy 7.5). How can I get support ?
Also I don't know where to start. Where is install instructions ?

I'm no way an expert on Linux. So should I go with something else ?
Maybe someone in here can help me get the system up running ?

You can install onto newer

You can install onto newer operating systems. I am running docsis_server 3.5 on wheezy 7.6 right now, it just took some config script patching to handle new package check variables. I'm still debugging dhcp issues, but i think it is more docsis_server itself, and less the operating system with the issues i am having.

There isn't really any "support" in the sense of something like a commercial product. You have places like here that can help out in a pinch, but this is probably not something you want to run production if you are going into this blind on all fronts, because you will need to be able to handle at least doing things like getting logs from SQL and debug logs from CLI to get help from others.

Not trying to run you off, but merely show you the scope of what the project is now a days from what I have experienced.

It could be nice to have this

It could be nice to have this project up running on newer OS. Also if we could make it useable for production. I'm about to install a lot of very small networks now that CMTS is becoming so cheap that it's affordable for smaller installations.

I would gladly host a Wordpress site with instructions/guides etc.

Can it not be statically made

Can it not be statically made to use aclocal-1.9??

cd . && automake-1.9 --foreign
/bin/sh: line 4: automake-1.9: command not found
Makefile:192: recipe for target '' failed
make: *** [] Error 1

aclocal --version
aclocal (GNU automake) 1.14.1

Problem MTA

Hi, when use modem with MTA give me this problem
works fine modem without mta
my linux Ubuntu 12.0.4 server
how i can fixed?

thanks for you help.

load /2 0 high(16) diff 1422284496
LOG docsis_server DHCP version 3.5 activated
*** stack smashing detected ***: /usr/local/sbin/docsis_server terminated
======= Backtrace: =========
======= Memory map: ========
08048000-08060000 r-xp 00000000 fc:00 1436219 /usr/local/sbin/docsis_server
08060000-08061000 r--p 00018000 fc:00 1436219 /usr/local/sbin/docsis_server
08061000-08062000 rw-p 00019000 fc:00 1436219 /usr/local/sbin/docsis_server
08062000-08063000 rw-p 00000000 00:00 0
0980a000-0982b000 rw-p 00000000 00:00 0 [heap]
0982b000-0984b000 rw-p 00000000 00:00 0 [heap]
b6900000-b6921000 rw-p 00000000 00:00 0
b6921000-b6a00000 ---p 00000000 00:00 0
b6a33000-b6a3e000 r-xp 00000000 fc:00 1702995 /lib/i386-linux-gnu/
b6a3e000-b6a3f000 r--p 0000a000 fc:00 1702995 /lib/i386-linux-gnu/
b6a3f000-b6a40000 rw-p 0000b000 fc:00 1702995 /lib/i386-linux-gnu/
b6a40000-b6a41000 ---p 00000000 00:00 0
b6a41000-b7241000 rw-p 00000000 00:00 0
b7241000-b7243000 rw-p 00000000 00:00 0
b7243000-b725f000 r-xp 00000000 fc:00 1697324 /lib/i386-linux-gnu/
b725f000-b7260000 r--p 0001b000 fc:00 1697324 /lib/i386-linux-gnu/
b7260000-b7261000 rw-p 0001c000 fc:00 1697324 /lib/i386-linux-gnu/
b7261000-b728b000 r-xp 00000000 fc:00 1703000 /lib/i386-linux-gnu/
b728b000-b728c000 r--p 00029000 fc:00 1703000 /lib/i386-linux-gnu/
b728c000-b728d000 rw-p 0002a000 fc:00 1703000 /lib/i386-linux-gnu/
b728d000-b7290000 r-xp 00000000 fc:00 1702997 /lib/i386-linux-gnu/
b7290000-b7291000 r--p 00002000 fc:00 1702997 /lib/i386-linux-gnu/
b7291000-b7292000 rw-p 00003000 fc:00 1702997 /lib/i386-linux-gnu/
b7292000-b72a6000 r-xp 00000000 fc:00 1697511 /lib/i386-linux-gnu/
b72a6000-b72a7000 r--p 00013000 fc:00 1697511 /lib/i386-linux-gnu/
b72a7000-b72a8000 rw-p 00014000 fc:00 1697511 /lib/i386-linux-gnu/
b72a8000-b744c000 r-xp 00000000 fc:00 1703010 /lib/i386-linux-gnu/
b744c000-b744e000 r--p 001a4000 fc:00 1703010 /lib/i386-linux-gnu/
b744e000-b744f000 rw-p 001a6000 fc:00 1703010 /lib/i386-linux-gnu/
b744f000-b7453000 rw-p 00000000 00:00 0
b7453000-b746a000 r-xp 00000000 fc:00 1703004 /lib/i386-linux-gnu/
b746a000-b746b000 r--p 00016000 fc:00 1703004 /lib/i386-linux-gnu/
b746b000-b746c000 rw-p 00017000 fc:00 1703004 /lib/i386-linux-gnu/
b746c000-b746e000 rw-p 00000000 00:00 0
b746e000-b770a000 r-xp 00000000 fc:00 1312107 /usr/lib/i386-linux-gnu/
b770a000-b770d000 r--p 0029c000 fc:00 1312107 /usr/lib/i386-linux-gnu/
b770d000-b7783000 rw-p 0029f000 fc:00 1312107 /usr/lib/i386-linux-gnu/
b7783000-b7786000 rw-p 00000000 00:00 0
b778b000-b778c000 rw-p 00000000 00:00 0
b778c000-b778e000 rw-p 00000000 00:00 0
b778e000-b778f000 r-xp 00000000 00:00 0 [vdso]
b778f000-b77af000 r-xp 00000000 fc:00 1702994 /lib/i386-linux-gnu/
b77af000-b77b0000 r--p 0001f000 fc:00 1702994 /lib/i386-linux-gnu/
b77b0000-b77b1000 rw-p 00020000 fc:00 1702994 /lib/i386-linux-gnu/
bfe9b000-bfebc000 rw-p 00000000 00:00 0 [stack]


hi, i created some test with docsis_server and i have some problems with MTA, when use modem without mta system works fine, but i put one with mta and gone up get DHCP, the services docsis_server deamon(DHCP) stopped...., i need restart docsis_server to work's again, request DHCP for mta the services stopped again.

sorry my english

my config_opts
1 1 54 IP 0 Lease Server IP
1 1 6 IP 0 DNS Servers
1 1 15 CHAR pek.cable.mta 0 Domain Name
1 1 2 INT32 -7200 0 Time Offset
1 1 4 IP 0 Time Server
1 1 7 IP 0 Log Server
1 1 66 CHAR 0 TFTP Server
1 1 3 IP 0 Router
1 100 54 IP 0 Lease Server IP
1 100 6 IP, 0 DNS Servers
1 100 15 CHAR 0 Domain Name
1 1 122 MTA-IP, 0 TSP's primary DHCP-Server
1 101 6 IP 0 DNS Servers
1 101 15 CHAR pek.cable.mta 0 Domain Name
1 101 2 INT32 -7200 0 Time Offset
1 101 7 IP 0 Log Server
1 101 122 MTA-REALM,BASIC.1 0 MTA-ProvisioningServer,REALM
1 101 54 IP 0 Lease Server IP

i need help to fixed this problem...

I would love to see what you

I would love to see what you had to do, because DHCP leasing to CPE devices built into cable gateways is what is failing on my instance of docsis_server, and in turn making it completely useless for production.

If i could get this thing running and know that it was working, I've been documenting what i had to change in setup files to work on modern instances of *nix so that this could be a semi-autonomous setup again, and would love to share it with git.


could you please provide some pcap-files and maybe docsis-server-logs to understand what your problem is?

I have a lot of modems with integrated routers running and there seems not to be an issue.

Could you please also post your network-config?
select * from config_nets;



Went ahead and updated to your latest repo since I saw some options for 125 being wrote in, plus we may eventually support mta's so i thought do it now before production. Still no change in combo docsis 3 units and CPE addresses.



Snippet of sys_log with failing d3.0 and successful d2.0 modem

"2014-12-04","19:06:18","1","6","FOUND MAC 0019a68ba09a CM"
"2014-12-04","19:06:20","1","6","FOUND MAC 0019a68ba09a CM"
"2014-12-04","19:06:22","1","4","file fnum 1 - blocks read 1"
"2014-12-04","19:06:29","1","1","ERROR: Executable not found (alert-program)"
"2014-12-04","19:06:31","1","6","FOUND MAC 00222dca7505 CM"
"2014-12-04","19:06:31","1","6","FOUND MAC 00222dca7505 CM"
"2014-12-04","19:06:33","1","4","file fnum 2 - blocks read 1"
"2014-12-04","19:06:36","1","6","FOUND MAC 00222dca7508 UNKNOWN"
"2014-12-04","19:06:36","1","4","NAK -- CPE asking for new IP directly - mac 00222dca7508"
"2014-12-04","19:06:39","1","6","FOUND MAC 00222dca7508 UNKNOWN"
"2014-12-04","19:06:39","1","4","NAK -- CPE asking for new IP directly - mac 00222dca7508"
"2014-12-04","19:06:48","1","6","FOUND MAC 00222dca7508 UNKNOWN"
"2014-12-04","19:06:48","1","4","NAK -- CPE asking for new IP directly - mac 00222dca7508"
"2014-12-04","19:06:48","1","6","FOUND MAC 7cbfb14b0a5b CM"
"2014-12-04","19:06:48","1","6","FOUND MAC 7cbfb14b0a5b CM"
"2014-12-04","19:07:03","1","6","FOUND MAC 00222dca7508 UNKNOWN"
"2014-12-04","19:07:03","1","4","NAK -- CPE asking for new IP directly - mac 00222dca7508"
"2014-12-04","19:07:34","1","6","FOUND MAC 00222dca7508 UNKNOWN"
"2014-12-04","19:07:34","1","4","NAK -- CPE asking for new IP directly - mac 00222dca7508"
"2014-12-04","19:08:16","1","6","FOUND MAC 00222dca7508 UNKNOWN"
"2014-12-04","19:08:16","1","4","NAK -- CPE asking for new IP directly - mac 00222dca7508"
"2014-12-04","19:08:54","1","6","FOUND MAC 0019a68ba09e UNKNOWN"
"2014-12-04","19:08:54","1","4","NEW IP addresses to give to gi mac 0019a68ba09e lease 0 docsis type 0"
"2014-12-04","19:08:54","1","6","NEW DYNAMIC -- mac 0019a68ba09e ip vlan 1"
"2014-12-04","19:08:56","1","6","FOUND MAC 0019a68ba09e CPE"
"2014-12-04","19:08:58","1","6","FOUND MAC 0019a68ba09e CPE"
"2014-12-04","19:09:19","1","6","FOUND MAC 00222dca7508 UNKNOWN"
"2014-12-04","19:09:19","1","4","NAK -- CPE asking for new IP directly - mac 00222dca7508"
"2014-12-04","19:09:29","1","6","FOUND MAC 00222dca7508 UNKNOWN"
"2014-12-04","19:09:29","1","4","NAK -- CPE asking for new IP directly - mac 00222dca7508"
"2014-12-04","19:09:34","1","6","FOUND MAC 00222dca7508 UNKNOWN"
"2014-12-04","19:09:34","1","4","NAK -- CPE asking for new IP directly - mac 00222dca7508"

Snippet of dhcp_log showing success of cm ip, but fail on getting a cpe ip (mac is 3 digits up, key identifier for a combo modem router):


It signifies the cpe is asking for the ip directly like a cm, but the docsis 3 combo units are using the same config file and layout on docsis_modem as the 1.1/2.0 combo units. The 1.1/2.0 units grab both a cpe and cm ip address just fine.

If you need the packet capture, I'll run to the head-end and get one on wireshark for you this evening if that is ok.

missing informations


could you please also post your config:

select * from config_opts;
select * from docsis_modems;
select * from docsis_update;

thank you and best regaes,



"1","1","54","IP","","0","Lease Server IP"
"1","1","2","INT32","-14400","0","Time Offset"
"1","1","4","IP","","0","Time Server"
"1","1","66","IP","","0","TFTP Server"
"1","100","54","IP","","0","Lease Server IP"
"1","100","6","IP","","0","DNS Servers"
"1","1","7","IP","","0","Log Server"
"1","1","6","IP","","0","DNS Server"
"1","100","15","CHAR","","0","Domain Name"
"1","1","122","MTA-IP",",","0","TSP's primary DHCP-Server"
"1","1","15","CHAR","","0","Domain Name"




"0019a68ba09a","","",,"2.0","YES","v2.0","YES","YES","YES","BPI+","15","4","NO","NO","1","24","YES","2014-12-16 03:20:20"
"00222dca7505","",,,,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,"2014-12-04 19:16:28"
"7cbfb14b0a5b","",,,,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,NULL,"2014-12-05 18:41:20"



what I found so far:
| 1 | 1 | 3 | IP | | 0 | Router |
| 1 | 1 | 122 | MTA-IP |, | 0 | TSP's primary DHCP-Server |

please remove the router-statement as this is automatically created by config_nets-options.
the Option 122 enables the MTA (if exists) please make sure your MaxCPE-Setting is at least 2.

| modem_macaddr | cmts_vlan | serialnum | subnum | config_file | dynamic_config_file | static_ip | dynamic_ip | config_opt |
| 0019A68BA09A | 1 | 002 | 0 | | 0 | 0 | 2 | 1 |
| 00222DCA7505 | 1 | 003 | 9900 | | 0 | 0 | 2 | 1 |

subnum is according devicespecific dhcp-options in the table "config_opts_macs" and
required for the mta-hostname for example, have you set this option?

please set dynamic_ip to 0 and config_opt to 0.
config_opt is according the dynamic-bootfileoptions.

| modem_macaddr | ipaddr | cmts_ip | agentid | version |
| 7cbfb14b0a5b | | | | |

in this table the gatewayinformation is missing as well as the agentid, this is also missing within the docsis2.0 request,
please make sure the cmts acts as a dhcp-relay and fills in the the option82-information.


I was using subnum honestly

I was using subnum honestly as what i thought it was intended for, a subscriber billing number. Documentation is slack to say the least with docsis_server, so I took a stab on that one and used it for what i thought it was for. I reset the 9900 back to a 0.

I made all the rest of your changes as recommended and did a clear cable modem reset to let the modems come online. docsis 2.0 modem come online just fine, same failure with the 3.0 modem. The 2.0 modem is filling out everything in docsis_update aside from agentid at this point, docsis 3.0 modems are still filling out nothing.

I'm thinking that I setup giaddr relay on this CMTS, but that may very well be the issue. I'll investigate.

Thanks for the help, and also for some clarification and descriptions for what certain fields pertain to.

Ive played around some more

Ive played around some more with this, and even messed with all the giaddr options on the Casa CMTS that i can find documentation for, but absolutely can not get this working on D3 modems.

I have to be missing something simple. Is anyone else using CASA gear with this working? I'd love to see some rededicated example configs, and I am willing to post up configs or give access to anything needed to debug this, as this has become a show stopper on our D3 deployment.

I've uploaded a pcap of the dhcp traffic on the docsis_server when the three test modems come online, just rename the txt file to pcap (forum extension restrictions). Transaction ID 0x39fa2b62 is the first transaction where the SMC docsis 3 combo unit asks, and gets rejected, for a public address. Transaction ID 0x625a shows an SBG900 docsis 2 combo unit successfully get a cpe address.

File attachments: 

Sorry, Dupe Post

Dear Sir

Dear Sir

Is docsis-server can assign static IP address by Mac address?

Many thanks



yes it should be able to handle static IPs. I have not needed this feature but the initally Author intended to use them.

please refere to:
- Enter the "docsismodem" data
cfg_static_ip, cfg_dynamic_ip - the number of IP addresses reserved for the specific CPE devices.

If you have trouble getting it work please let me know.


Hello schirrmeister

Hello schirrmeister

Is the git docsis-server project create from you ?

I have see the "cfg_static_ip" this very long time ago , but i don't find any assign target for static IP Address . like assign IP Address by CPE Mac Address.


Log in or register to post comments