CISCO UBR7111 - DHCP PROBLEM | docsis.org

You are here

CISCO UBR7111 - DHCP PROBLEM

6 posts / 0 new
Last post
vixxant
CISCO UBR7111 - DHCP PROBLEM

I Am trying to configure a ubr7111.. i want to set 2 dhcp pools 10.100.0.0/24 for the modem pool which is primary and 10.1.0.0/21 for the cpe pool which is secondary. Modems are getting online just fine .. but the only problem is that cpe is getting ip's from the modem pool. Here is my current running-config PLS HELP.

!
version 12.3
no service pad
service timestamps debug datetime msec localtime
service timestamps log datetime localtime
no service password-encryption
service udp-small-servers max-servers no-limit
!
hostname cisco
!
boot-start-marker
boot-end-marker
!
enable secret 5 ##################################
!
clock timezone UTC+5 5
clock calendar-valid
no cable qos permission create
no cable qos permission update
cable qos permission modems
cable time-server
!
cable config-file 3MD_2MU.cm
service-class 1 max-upstream 2048
service-class 1 guaranteed-upstream 10
service-class 1 max-downstream 3072
service-class 1 max-burst 1600
cpe max 3
timestamp
!
cable config-file 2MD_2MU.cm
service-class 1 max-upstream 2048
service-class 1 guaranteed-upstream 10
service-class 1 max-downstream 2048
service-class 1 max-burst 1600
cpe max 3
!
cable config-file 5MD_2MU.cm
service-class 1 max-upstream 2048
service-class 1 guaranteed-upstream 10
service-class 1 max-downstream 5120
service-class 1 max-burst 1600
cpe max 3
!
no aaa new-model
ip subnet-zero
no ip routing
!
!
no ip cef
no ip domain lookup
ip dhcp excluded-address 10.1.3.0 10.1.7.254
ip dhcp excluded-address 10.1.0.1
ip dhcp relay information option
no ip dhcp relay information check
!
ip dhcp pool CableModems
network 10.100.0.0 255.255.255.0
bootfile 3MD_2MU.cm
next-server 10.100.0.1
default-router 10.100.0.1
option 7 ip 10.100.0.1
option 4 ip 10.100.0.1
option 2 hex 0000.4650
lease 7 0 10
!
ip dhcp pool EndUsers
network 10.1.0.0 255.255.248.0
next-server 10.1.0.1
default-router 10.1.0.1
dns-server 10.1.0.1
lease 7 0 10
!
!
!
!
!
bridge irb
!
!
interface FastEthernet0/0
no ip address
ip access-group 101 in
ip access-group 101 out
no ip route-cache
no ip mroute-cache
duplex half
speed auto
no keepalive
no cdp enable
bridge-group 1
bridge-group 1 spanning-disabled
!
interface FastEthernet0/1
no ip address
no ip route-cache
shutdown
duplex auto
speed auto
no cdp enable
!
interface Cable1/0
no ip address
no ip route-cache
no ip mroute-cache
load-interval 30
no cable packet-cache
cable downstream annex B
cable downstream modulation 64qam
cable downstream interleave-depth 32
cable downstream frequency 471000000
cable downstream channel-id 0
no cable downstream rf-shutdown
cable upstream 0 frequency 32000000
cable upstream 0 channel-width 3200000
cable upstream 0 minislot-size 2
cable upstream 0 power-level 0
cable upstream 0 modulation-profile 1
no cable upstream 0 shutdown
cable arp filter request-send 3 2
cable arp filter reply-accept 3 2
cable dhcp-giaddr policy
no keepalive
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 spanning-disabled
!
interface BVI1
ip address 10.1.0.2 255.255.248.0 secondary
ip address 192.168.100.2 255.255.255.0 secondary
ip address 10.100.0.1 255.255.255.0
no ip route-cache
!
ip default-gateway 192.168.100.1
ip classless
no ip http server
no ip http secure-server
!
!
access-list 101 deny udp any any eq bootps
access-list 101 deny udp any any eq bootpc
access-list 101 permit ip any any
no cdp run
!
!
bridge 1 protocol ieee
bridge 1 route ip
alias exec scm show cable modem
alias exec scmr show cable modem remote
!
line con 0
exec-timeout 0 0
transport output all
line aux 0
transport output all
line vty 0 4
password ####
login
transport input all
transport output all
line vty 5 15
password ####
login
transport input all
transport output all
!
end

kwesibrunee
I would suspect that the

I would suspect that the order of your secondary networks is to blame

you have the command cable dhcp-giaddr policy

which tells the CMTS to use the primary address for modems and the secondary address for clients

the problem is your first secondary address is 192.168.x.x which you have no dhcp pool for try removing that ip range from your bundle and/or add a dhcp pool for 192.168 and you should be in business

vixxant
Dasn't Work

When i remove the 192.168.x.x subnet it's still the same .... so what do you think ?? any other suggestions !

kwesibrunee
I mistook your interface

I mistook your

interface BVI1

for

interface Bundle 1

I have never tried setting up a cisco CMTS with a bridge group before not sure how that works, you should try a cable bundle instead

i.e.

interface cable 1/0
cable bundle 1

interface bundle 1
ip address 10.1.0.2 255.255.248.0 secondary
ip address 10.100.0.1 255.255.255.0

and get rid of your bridge group commands.

its the same concept except cable bundles are designed for cable blades. Since this is a 7111 you could also get rid of the bundle/bridge group altogether and just put the ips on the cable interface.

one last thing you may need to add the cable dhcp-giaddr to the bundle as well.

vixxant
Done .. but am facing another prob :(

i have removed the bridge group commands from the fast Ethernet 0/0 and cable 1/0 . and added both ranges to cable 1/0 like
ip address 10.1.0.2 255.255.248.0 secondary
ip address 10.100.0.1 255.255.255.0

I am able to get ip for the cpe's , with the gw as 10.1.0.1 which is a router which is running hotspot and it's connected to FE 0/0
But the problem that i am facing is i am not able to reach (ping ) the router from the cpe which the behind the cable modem .. what do you think the problem is ??

kwesibrunee
Gateway problem.... you are

Gateway problem....

you are giving the CPEs a gateway of 10.1.0.1, as far as I can tell from your config 10.1.0.1 does not exist on your router, so either one of two things are happening

1. you have 10.1.0.1 on another device and your 7111 can't reach it. I would look at the ip default-gateway line if this is the case, one other possibility, check to make sure that ip routing is enabled, cisco routers if set back to factory defaults, can default to having routing disabled. (this has burned me at least once and is simple to miss)

2. you really meant to set 10.1.0.1 as the secondary ip on the cable blade and typoed it

remedy that and you should be in business let us know how it goes

Thanks,
Jason

Log in or register to post comments