Please help with PacketCable | docsis.org

You are here

Please help with PacketCable

6 posts / 0 new
Last post
Anonymous (not verified)
Please help with PacketCable

Hi all,
We have Motorola BSR 2000 and emta Motorola SBV5121E . CM work fine on this modem, now we want configure PacketCableю I try configure it self but no luck:( On this forum http://docsis.org/node/83 have some info but not 100% worked configs, please someone who have this configs(ISC DHCP,CM,EMTA) share its here.

Thanks.

veno (not verified)
Hi, I see you are using

Hi,

I see you are using eurodocsis, if not correct me.
You will need the following in the dhcp server(I am giving you one of the examples, there are different ways to achieve this):

option mtaopt122 code 122 = string;
class "reserved_modems" {
match option dhcp-client-identifier;
lease limit 20;
}

class "reserved_mta" {
match option dhcp-client-identifier;
lease limit 20;
}
subnet 192.168.105.0 netmask 255.255.255.0 {
option domain-name "example.com";
option time-servers 192.168.102.1;
option time-offset 7200;
default-lease-time 86400;
max-lease-time 604800;
pool {
option routers 192.168.105.1;
option domain-name-servers 192.168.102.1;
next-server 192.168.102.1;
allow members of "reserved_modems";
range 192.168.105.11 192.168.105.111;
}
}

subnet 192.168.106.0 netmask 255.255.255.0 {
option domain-name "kst-bg.com";
option time-servers 192.168.102.1;
option time-offset 7200;
default-lease-time 86400;
max-lease-time 604800;
pool {
option routers 192.168.106.1;
option domain-name-servers 192.168.102.1;
next-server 192.168.102.1;
allow members of "reserved_mta";
range 192.168.106.11 192.168.106.111;
}
}

}
subclass "reserved_modems" 1:00:15:2F:8F:83:E4 {
option host-name "sbv5120" ;
option mtaopt122 01:04:c0:a8:0a:01; (Suboption number = 1 ; Data Length = 4 Bytes ; DHCP Ip Address, Hex Encoded = 192.168.10.1 (TSP's DHCP Server Address ))
filename "sbv5120.md5";
}
subclass "reserved_mta" 1:00:15:2F:8F:83:E6 {
option host-name "mmta1" ;
option mtaopt122 03:13:00:05:6c:6f:63:61:6c:06:62:6F:73:74:6F:6E:03:63:6f:6d:00:06:09:05:42:41:53:49:43:01:31
:00 ; (This includes suboption 03 which is local.boston.com ; and suboption 06 - which is BASIC.1)

option log-servers 192.168.102.1;
filename "mmta.md5";
}

CM config:
You need:
VendorSpecific
{
VendorIdentifier 0x002040;
GenericTLV TlvCode 168 TlvLength 1 TlvValue 0x01;
}
(MTA ignore configuration file Hash Code )

MTA config:

Main
{
MtaConfigDelimiter 1;
SnmpMibObject enterprises.7432.1.1.1.6.0 Integer 1 ;
SnmpMibObject ifAdminStatus.9 Integer 1; /* up */
SnmpMibObject enterprises.7432.2.1.2.1.1.1.9 String "ca@cms.boston.com" ;
SnmpMibObject enterprises.7432.2.1.2.1.1.2.9 Gauge32 2427 ; (Depends on the CMS could be 2727)
SnmpMibObject enterprises.7432.2.1.2.1.1.18.9 Gauge32 1 ;
SnmpMibObject enterprises.7432.1.1.3.6.1.5.1 String "BOSTON.COM" ;
SnmpMibObject enterprises.7432.1.1.3.8.1.3.1 String "CMS.BOSTON.COM" ;
SnmpMibObject enterprises.7432.1.1.3.8.1.9.1 Integer 2 ;
SnmpMibObject enterprises.7432.1.1.3.6.1.2.1 String "CMS.BOSTON.COM" ;
SnmpMibObject enterprises.7432.1.1.3.8.1.2.1 String "cms.boston.com" ;
SnmpMibObject enterprises.7432.2.1.1.15.0 Integer 24 ;
SnmpMibObject enterprises.7432.2.1.1.16.0 Integer 40 ;
MtaConfigDelimiter 255;
}

PRESERVE the upper/lower cases!!!
This is basic mta config file for eurodocsis firmware which supports Euro-PacketCable MIBs (also called IETF).

warp (not verified)
Big thanks veno. Yes we use

Big thanks veno. Yes we use EuroDocsis. I try our configs on next week.

rchudasama
PacketCable

Hi would the configuration on EMTA change for Packetcable - American standards ?

warp (not verified)
Huh, i dont understand what

Huh, i dont understand what him need, MTA start but on logs for DHCP i see next :

dhcpd: DHCPOFFER on 10.11.0.21 to 00:1a:ad:99:2d:54 via 10.11.0.1
dhcpd: DHCPDISCOVER from 00:1a:ad:99:2d:54 via 10.11.0.1
dhcpd: DHCPOFFER on 10.11.0.21 to 00:1a:ad:99:2d:54 via 10.11.0.1
dhcpd: DHCPDISCOVER from 00:1a:ad:99:2d:54 via 10.11.0.1
dhcpd: DHCPOFFER on 10.11.0.21 to 00:1a:ad:99:2d:54 via 10.11.0.1
dhcpd: DHCPDISCOVER from 00:1a:ad:99:2d:54 via 10.11.0.1
dhcpd: DHCPOFFER on 10.11.0.21 to 00:1a:ad:99:2d:54 via 10.11.0.1

and nothing more. What default login/password for SBV5121E for telnet? Maybe in console i can see debug?

dhcpd version:
Internet Systems Consortium DHCP Server 4.0.0b3

This my dhcpd.conf:

ddns-update-style ad-hoc;
#
#######################
# CM subnet #
#######################
#

use-host-decl-names on;

option option-122 code 122 = string;

subnet 10.11.0.0 netmask 255.255.255.0 {
option routers 10.11.0.1;
option domain-name "test.com";
option time-servers 10.2.0.2;
option time-offset 7200; # 10800 for winter time
default-lease-time 86400;
option domain-name-servers 83.69.81.66;
range 10.11.0.20 10.11.0.254;
max-lease-time 604800;
next-server 10.2.0.2;
}

subnet 10.3.0.0 netmask 255.255.0.0 {

option routers 10.3.0.1;
option subnet-mask 255.255.0.0;
option domain-name "test.com";
option broadcast-address 10.0.255.255;
option ntp-servers 10.2.0.2;
option time-servers 10.2.0.2;
option time-offset 14400; # 10800 for winter time
option tftp-server-name "10.2.0.2";
range 10.3.0.20 10.3.0.254;
default-lease-time 21600;
max-lease-time 43200;

next-server 10.2.0.2;
filename "ds.cm";

}

host modem-SBV5121-SNMP-E_1_1.modemy {
hardware ethernet 00:1A:AD:99:2D:52;
fixed-address 10.3.0.9;
filename "ds.bin";
option option-122 01:04:0A:02:00:02;
}

host mmta {
hardware ethernet 00:1A:AD:99:2D:54;
fixed-address 10.11.0.21;
filename "mta.bin";
option option-122 03:13:00:05:6c:6f:63:61:6c:06:62:6F:73:74:6F:6E:03:63:6f:6d:00:06:09:05:42:41:53:49:43:01:31:00 ;
}

subnet 10.2.0.0 netmask 255.255.255.0 {
}

CM config:

Main
{
NetworkAccess 1;
ClassOfService
{
ClassID 1;
MaxRateDown 50000000;
MaxRateUp 10000000;
PrivacyEnable 0;
}
MaxCPE 4;
VendorSpecific
{
VendorIdentifier 0x002040;
GenericTLV TlvCode 168 TlvLength 1 TlvValue 0x01;
}

/* CmMic 2a87c06c5580edc43fe4e1de5c52a283; */
/* CmtsMic cb36ceb90121017653777e7f017bf6f2; */
/*EndOfDataMkr*/

BSR 2000:

atk-ktv#sh run
!
! Last configuration change at FRI JUL 23 23:08:51 2066
!
!
!
enable password 0 xxxxxxxxxxxxxxxxxxx
!
hostname atk-ktv
!
!
!
no service password-encryption
!
username atk user-group sysadmin
username atk password 0 xxxxxxxxxxxxxxxx
!
ip ftp username anonymous
ip ftp password 0 32432rwefe
!
ip name-server 83.69.81.66
!
logging buffered 51200
logging control docsis
logging admin-status unconstrained
logging rate-limit 100 1
logging reporting debug local-trap-syslog
logging buffered notifications
logging console errors
!
!
cable cmts type euro
!
!
interface ethernet 0/0
speed 100
shutdown
!
interface ethernet 0/1
ip address 10.2.0.3 255.255.255.0
no shutdown
!
interface ethernet 0/2
shutdown
!
interface ethernet 0/3
shutdown
!
interface gigaether 0/0
shutdown
!
interface gigaether 0/1
shutdown
!
interface cable 0/0
ip address 10.3.0.1 255.255.0.0
ip address 10.11.0.1 255.255.255.0 secondary mta
ip helper-address 10.2.0.2
cable helper-address 10.2.0.2 cable-modem
cable helper-address 10.2.0.2 host
cable helper-address 10.2.0.2 mta
no shutdown
cable downstream 0 frequency 410000000
no cable downstream 0 shutdown
cable upstream 0/0 channel-type atdma
cable upstream 0 frequency 50000000
cable upstream 0/0 force-frag 48
no cable upstream 0 shutdown
no cable upstream 0/0 shutdown
cable upstream 0/0 maintain-power-density on
cable upstream 0/1 channel-type atdma
no cable upstream 0/1 shutdown
cable upstream 0/2 channel-type atdma
no cable upstream 0/2 shutdown
cable upstream 0/3 channel-type atdma
no cable upstream 0/3 shutdown
cable upstream 1/0 channel-type atdma
cable upstream 1 frequency 40000000
cable upstream 1/0 force-frag 48
no cable upstream 1 shutdown
no cable upstream 1/0 shutdown
cable upstream 1/1 channel-type atdma
no cable upstream 1/1 shutdown
cable upstream 1/2 channel-type atdma
no cable upstream 1/2 shutdown
cable upstream 1/3 channel-type atdma
no cable upstream 1/3 shutdown
cable upstream 2/0 channel-type atdma
cable upstream 2 frequency 30000000
no cable upstream 2 shutdown
no cable upstream 2/0 shutdown
cable upstream 2/1 channel-type atdma
no cable upstream 2/1 shutdown
cable upstream 2/2 channel-type atdma
no cable upstream 2/2 shutdown
cable upstream 2/3 channel-type atdma
no cable upstream 2/3 shutdown
cable upstream 3/0 channel-type atdma
cable upstream 3 frequency 20000000
no cable upstream 3 shutdown
no cable upstream 3/0 shutdown
cable upstream 3/1 channel-type atdma
no cable upstream 3/1 shutdown
cable upstream 3/2 channel-type atdma
no cable upstream 3/2 shutdown
cable upstream 3/3 channel-type atdma
no cable upstream 3/3 shutdown
cable dynamic-service authorization-mode unauthorize
ip dhcp relay information option
cable flap-list aging 5
cable flap-list power-adjust threshold 3
cable downstream schedule priority-wfq
no cable wireless downstream modulation qpsk
!
!
!
!
!
!
!
ip route 0.0.0.0 0.0.0.0 10.2.0.2
!
!
!
!
!
packet-cable
cmts-ip 10.11.0.1
no dqos shutdown
no em shutdown
no es shutdown
!
!
ipsec
ipsec shutdown
!
!
session-timeout console 0
session-timeout telnet 0
!
telnet session-limit 2
!
!
!
access-list 100 permit ip host 10.2.0.2 10.3.0.0 0.0.255.255
access-list 100 permit ip 10.3.0.0 0.0.255.255 host 10.2.0.2
access-list 100 permit udp any any eq bootpc
access-list 100 permit udp any any eq bootps
!
!
!
!
ssh timeout 60
ssh enable
!
!
logging on
no logging trap
no logging snmp-trap
logging facility local7
logging 83.69.81.75
!
sntp timer 1
sntp server 10.2.0.3
clock timezone MSK 3 0 daylightsavings off
!
!
!
!
!
!
time-of-day server 10.2.0.2
enable rdn-process
!
!
!
!
cable service-class
!
!
!
!
!
!
!

hrguille (not verified)
.

.