Differentiating cable modem transfer rate during day | docsis.org

You are here

Differentiating cable modem transfer rate during day

6 posts / 0 new
Last post
kulawymoe
Differentiating cable modem transfer rate during day

Hello,
My goal is to increase bandwidth availabe to users from certain time of day (for example to increase transfer from midnight). Afaik its possible to achieve this thing without the need to reset cable modems by creating additional service flow with increased MaxRateSustained parameter. However i do not know how to make the transition from normal traffic flow during the day to the increased one. Do i need special classifier or is it done on CMTS? I have Arris C3 CMTS and for provisioning ISC DHCP, TFTP Server on Debian. Thanks in advance for help and sorry for my english.

Regards
Adam

m4sh
Re: Differentiating cable modem transfer rate during day

Yes, you must use another classifier, which you can control using external device marks packets. For example (on modem config):
UsServiceFlow
{
UsServiceFlowRef 1;
QosParamSetType 7;
TrafficPriority 7;
MaxRateSustained 2048000;
SchedulingType 2;
RequestOrTxPolicy 0x00000002;
}
DsServiceFlow
{
DsServiceFlowRef 101;
QosParamSetType 7;
TrafficPriority 1;
MaxTrafficBurst 16000;
MaxRateSustained 8192000;
MaxDsLatency 30000;
}
DsServiceFlow
{
DsServiceFlowRef 104;
QosParamSetType 7;
TrafficPriority 1;
MaxTrafficBurst 16000;
MaxRateSustained 14000000;
MaxDsLatency 30000;
}
DsPacketClass
{
ServiceFlowRef 104;
ClassifierRef 108;
RulePriority 100;
ActivationState 1;
IpPacketClassifier
{
IpTos 0x4040ff;
}

As you can see here is used to check the condition of TOS. TOS, you can marks for example on Cisco, like this:
[..]
class-map match-all TaryfaNocna
match access-group name CzasNocny
[..]
policy-map TaryfaNocna
class TaryfaNocna
set dscp cs2
[..]
interface GigabitEthernet1/2
description CMTS
service-policy output TaryfaNocna
(..)
[..]
ip access-list extended CzasNocny
permit ip any any time-range noc
[..]
time-range noc
periodic Monday 23:00 to Tuesday 15:00
periodic Tuesday 23:00 to Wednesday 15:00
periodic Wednesday 23:00 to Thursday 15:00
periodic Thursday 23:00 to Friday 15:00
periodic Sunday 23:00 to Monday 15:00
periodic Friday 23:00 to Saturday 9:00
periodic Saturday 23:00 to Sunday 9:00

In this example, you can see that marked packages are between the relevant hours. Of course, you can marked so on a different hardware (maybe also on CMTS if such a possibility).

elbasto
IpTos 0x4040ff

Hi, sorry for my English.
I don't understand this format of TOS : "IpTos 0x4040ff"
Can you help me with some links with information about Tos? I've read RFC 2474, but don't get it. TOS is a 8 bit header

Regards.

edgardor_maidana
IpTos explanation

http://www.cmtsinfo.net/index.php?howto=cm_config
Creating DOCSIS Cable modem configuration files
IP classifier parameters:
IpTos Matches ToS values 0xLLHHMM, where LL - low tos, HH -high tos, MM - tos mask. Matches packets, where LL >= (tos AND MM) <= HH.

elbasto
hi, sorry for my english

hi, sorry for my english
I did what m4sh said about marking packages, but it didnt work.
I did it in a Cisco 2960 y 2970 Cisco Switch
Can you help please? Any idea?

I did this:

SW1POP10#show running-config
Building configuration...

Current configuration : 3116 bytes
!
! Last configuration change at 18:23:34 ARG Fri Jan 20 2012 by maidanae
! NVRAM config last updated at 13:38:35 ARG Tue Jan 24 2012 by maidanae
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname SW1POP10
!
enable secret 5
!
username fernandez password 7
no aaa new-model
clock timezone ARG -3
ip subnet-zero
!
!
!
!
!
!
no file verify auto
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
class-map match-all classmap-nocturno
match access-group name acl-nocturno
!
!
policy-map policymap-nocturno
class classmap-nocturno
set dscp cs1
!
!
interface GigabitEthernet0/1
description al R3NOC
switchport access vlan 100
switchport mode access

interface GigabitEthernet0/2
!
interface GigabitEthernet0/3
!
interface GigabitEthernet0/4
!
interface GigabitEthernet0/5
!
interface GigabitEthernet0/6
!
interface GigabitEthernet0/7
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet0/8
!
interface GigabitEthernet0/9
!
interface GigabitEthernet0/10
switchport trunk encapsulation dot1q
switchport mode trunk
service-policy input policymap-nocturno
load-interval 30
!
interface GigabitEthernet0/11
!
interface GigabitEthernet0/12
!
interface GigabitEthernet0/13
!
interface GigabitEthernet0/14
!
interface GigabitEthernet0/15
!
interface GigabitEthernet0/16
!
interface GigabitEthernet0/17
!
interface GigabitEthernet0/18
description al CMTS1POP10-FE01
switchport access vlan 200
switchport mode access
!
interface GigabitEthernet0/19
!
interface GigabitEthernet0/20
description AL CACHE
switchport access vlan 200
switchport mode access
!
interface GigabitEthernet0/21
!
interface GigabitEthernet0/22
!
interface GigabitEthernet0/23
!
interface GigabitEthernet0/24
!
interface Vlan1
no ip address
no ip route-cache
!
interface Vlan200
ip address
no ip route-cache
!
ip default-gateway
ip http server
ip http secure-server
!
ip access-list extended acl-nocturno
permit ip any any time-range timerange-nocturno
!
control-plane
!
!
line con 0
line vty 0 4
login local
line vty 5 15
login local
!
ntp clock-period 36029312
ntp source GigabitEthernet0/10
ntp server 216.244.192.3 prefer
ntp server 200.10.140.2
time-range timerange-nocturno
periodic weekdays 16:00 to 20:00
periodic Friday 0:00 to 23:00
!
end

SW1POP10#

SW1POP10#show version
Cisco IOS Software, C2970 Software (C2970-LANBASEK9-M), Version 12.2(25)SEE1, RELEASE SOFTWARE (fc1)
Copyright (c) 1986-2006 by Cisco Systems, Inc.
Compiled Mon 22-May-06 07:54 by yenanh
Image text-base: 0x00003000, data-base: 0x00C888BC

ROM: Bootstrap program is C2970 boot loader
BOOTLDR: C2970 Boot Loader (C2970-HBOOT-M) Version 12.1(14r)EA1a, RELEASE SOFTWARE (fc1)

SW1POP10 uptime is 3 days, 23 hours, 38 minutes
System returned to ROM by power-on
System restarted at 17:03:48 ARG Fri Jan 20 2012
System image file is "flash:/c2970-lanbasek9-mz.122-25.SEE1/c2970-lanbasek9-mz.122-25.SEE1.bin"

This product contains cryptographic features and is subject to United
States and local country laws governing import, export, transfer and
use. Delivery of Cisco cryptographic products does not imply
third-party authority to import, export, distribute or use encryption.
Importers, exporters, distributors and users are responsible for
compliance with U.S. and local country laws. By using this product you
agree to comply with applicable laws and regulations. If you are unable
to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:
http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to
export@cisco.com.

cisco WS-C2970G-24T-E (PowerPC405) processor (revision L0) with 118784K/12280K bytes of memory.
Processor board ID CAT1038ZM3R
Last reset from power-on
2 Virtual Ethernet interfaces
24 Gigabit Ethernet interfaces
The password-recovery mechanism is enabled.

512K bytes of flash-simulated non-volatile configuration memory.
Base ethernet MAC Address : 00:19:56:BC:C8:00
Motherboard assembly number : 73-8754-08
Power supply part number : 341-0048-03
Motherboard serial number : CAT10385GD4
Power supply serial number : LIT10280DND
Model revision number : L0
Motherboard revision number : A0
Model number : WS-C2970G-24T-E
System serial number : CAT1038ZM3R
Top Assembly Part Number : 800-23385-05
Top Assembly Revision Number : A0
Hardware Board Revision Number : 0x01

Switch Ports Model SW Version SW Image
------ ----- ----- ---------- ----------
* 1 24 WS-C2970G-24T-E 12.2(25)SEE1 C2970-LANBASEK9-M

Configuration register is 0xF

SW1POP10#

edgardor_maidana
Differentiating cable modem transfer rate during day

I found in switch is necessary enable mls qos

Log in or register to post comments