casa c100g | docsis.org

You are here

casa c100g

34 posts / 0 new
Last post
kdavid
casa c100g

Hi all,

i decided to switch from our chinese mini cmtsses to something more professional - casa c100g

I am not a professional in docsis, but i cant find any manuals and example configurations on web for this device.

Is there anyone who can helsp me with manuals or som example configs.

I have also few question about casa c100.

1 - Does it support dynamic modulation for upstream to handle short noise changes on reverse path?

2- Is there any way to make RF Groups and join the to separate vlan? At this time i have One mini cmts per one village. SO now i want to have 1rf port or 32 channels DS/ 8 channels US joined to vlan and worl like a bridge.

Is there anyone who can helps me wit that beast?

Thank you
Sincerelly
Dave

kwesibrunee
What software version are you

What software version are you running? I can get you the appropriate documentation for your software release.

1. Yes you can specify a secondary Modulation profile for D3.0 modems. Casa also supports logical upstreams, where you can have 1 logical upstream at one modulation and/or width, and another logical upstream on a different modulation and/or width both centered at same frequency. That way you can move modems that have low SNR issues to lower modulation/width logical channels with Spectrum rules, rather than changing the modulation for everybody because a few modems have low SNR.

2. Casa C100G does not support Bridge mode (L2 VLANs) but it can do similar things with L3. You can configure multiple bundles and assign different mac Domains to the different IP Bundles, or you can add VRF if you need total isolation between IP Bundles.

I could get you an example config if you tell me what features you are looking for.

kdavid
Thank you for info... but

Thank you for info... but that is not good news for me that casa cant make bridge domain :( it will mess up my provisioning that is made now on mikrotiks or cisco asr where is dhcp server running.
Sincerelly
Dave

kwesibrunee
As long as your DHCP servers

As long as your DHCP servers have an IP that is reachable from the Casa ( you can create VLAN interfaces on the SMM interfaces to reach a VLANed network) you can use the cable helper-address to proxy all DHCP requests to the specified IP from either the primary address on the IP-Bundle or the secondary ip on the IP bundle, depending on whether you have cable dhcp-giaddr-primary set. So you should not have too much trouble.

kwesibrunee
Here is a barebones config

Here is a barebones config, you will need to supply the information in between < and >

File attachments: 
kdavid
Thank you for config file.

Thank you for config file.

With it i am able to connect the moden, but it receive only one IP fo CRM. For router it cant load ip.

When i add more IPs to ip-bundle the modem is not able to load config file.

interface ip-bundle 1
ip address 192.168.1.1 255.255.255.0
ip address 192.168.0.1 255.255.255.0 secondary
cable helper-address 10.0.0.1

For test i am using mikrotik dhcp. The mikrotik can ping modem IP, bude modem doesnt obtain IP to the wan interface (in case of one IP in ip bundle).

IP of casa is 10.0.0.2
IP of mikrotik is 10.0.0.1

Local network (nated and prerouted is ) 192.168.1.0/24 for internet and 192.168.0.0/24 for modems with config file

Can you helsp me pls?
Sincerelly
Dave

kwesibrunee
A little info on DHCP for

A little info on DHCP for DOCSIS

The CMTS acts as a L3 DHCP Proxy, meaning it forwards the L2 DHCP messages to a L3 endpoint, there are a few classes of devices that need to do this functionality, but to keep things simple lets think of it as two classes, CM and CPE. CPEs just need IP/SubnetMask/GW/DNS, CMs need the same (minus DNS) and special DHCP options like boot-file and next-server(tftp server).

If your using a single DHCP Server you need a way to differentiate between CMs and CPEs, you can do this a couple of ways:

option 1: CMs will always have the letters docsis followed by version number 1.0,1.1,2.0,3.0,3.1 in the vendor identifier of DHCPDISCOVER packets, if your dhcp server supports identifying CMS this way, you can point the CMs to the CM Subnet with the extra options, all other devices would go to the CPE subnet.

option 2: The CMTS can peek at the DHCP Discover packets looking for the docsis1.0, docsis2.0 etc in the vendor identifier and forward the dhcp packet to a different endpoint based on whether it is a CM or not. This is done by adding an identifier after the cable helper-address specifying whether it is a cable-modem or cpe. This requires two dhcp servers one for the cable-modems and one for the CPEs

When you have multiple Ips on your bundle you need a way to distinguish which IP to use as the giaddr (source network) of the DHCP request, the DHCP server will look at the giaddr and determine what pool to offer the device based on that. On the CMTS you can control which IP is set as the giaddr by adding the following statement to your docsis-macs (you have to do it to each one) dhcp-giaddr-primary -- this will select the first ip address on the IP-bundle as the giaddr, dhcp-giaddr-secondary -- this will select the first secondary ip-address on the IP bundle as the giaddr.

back on your DHCP server you need a way to combine networks/subnets together so that it listens on one subnet but gives an address from another.

using your config as an example
interface ip-bundle 1
ip address 192.168.1.1 255.255.255.0
ip address 192.168.0.1 255.255.255.0 secondary

if you had dhcp-giaddr-primary set on your docsis macs, DHCPDISCOVERs from CMs would be sent to your cable helper-address with a giaddr of 192.168.1.1, on you dhcp server it would look at its networks and if it had a 192.168.1.x and a pool on that network to hand off an IP. For a CPE the DHCPDISCOVERs would also be sent with a giaddr of 192.168.1.1 and on your dhcp server you would need a way to link the network 192.168.1.x with the network 192.168.0.x with a pool for 192.168.0.x. Some DHCP servers call this a shared-network.

I notice you have all non-routeable (private) Ips on your ip-bundle, unless your planning to NAT your customers this probably is not what you want. Typically most MSOs set up the ip-bundle with a non-routeable subnet for the modems and a routeable (public) ips for the CPEs

e.g.
interface ip-bundle 1
ip address 10.0.0.1 255.255.0.0
ip address secondary

Looking at the Microtik's dhcp server documentation, I am not sure it can be the dhcp server for both your CMs and CPEs. It does not appear to have the ability to combine networks needed to deploy typical docsis networks.

you could try setting up two dhcp servers on the microtik one for CMS and one for CPEs and then

interface ip-bundle 1
ip address 192.168.1.1 255.255.255.0
ip address 192.168.0.1 255.255.255.0 secondary
cable helper-address cable-modem
cable helper-address cpe

and see if that works.

Otherwise you may need a more flexible DHCP server, ISC dhcp server works well for this task and is open-source and I can surely give your a leg up on configuring it. the microtik could surely handle the CPE dhcp funtionality, or the CM dhcp functionality but probably not both.

Also important to note, Authorization in DOCSIS is typically done with DHCP (e.g. service level is controlled by what modem config is given, unauthorized modems are either not given an IP or given an IP with config that shuts network side of modem off) Microtiks DHCP server does not seem to have a notion of authorized / not authorized or the ability to easily change dhcp options to vary service levels for modems.

kdavid
No more duc block

Hello,

when i am trying to enable DS channels on channel from 25 and upper i receive this message:
CASA-C100G(config-if-qam 0/0)#no channel 25 shutdown
Error: no more duc block available on port 0 for channel 0/25

I am trying to enable 32 channels on port 0/0 but from 25 to 31 i receive this message.
How can i fix it pls?

output from show log:
Tue Jun 15 18:18:28 2021]-ER-CLI-1: smm6: Error: no more duc block available on port 0 for channel 0/28
[Tue Jun 15 18:18:17 2021]-ER-CLI-1: smm6: Error: no more duc block available on port 0 for channel 0/29
[Tue Jun 15 18:18:13 2021]-ER-CLI-1: smm6: Error: no more duc block available on port 0 for channel 0/31
[Tue Jun 15 18:17:56 2021]-ER-CLI-1: smm6: Error: no more duc block available on port 0 for channel 0/25(repeat count 2, last time Tue Jun 15 18:18:07 2021)
[Tue Jun 15 18:13:37 2021]-ER-CLI-1: smm6: Error: no more duc block available on port 0 for channel 0/26
[Tue Jun 15 18:13:19 2021]-ER-CLI-1: smm6: Error: no more duc block available on port 0 for channel 0/25(repeat count 2, last time Tue

dave

kwesibrunee
You would need to post your

You would need to post your QAM config to confirm, but it is likely because you do not have contiguous channels

Please post your QAM config and I can comment further.

kdavid
Here is my qam config:

Here is my qam config:
interface qam 0/0
interleave 16
channel 0 frequency 434000000
no channel 0 shutdown
channel 1 frequency 442000000
no channel 1 shutdown
channel 2 frequency 450000000
no channel 2 shutdown
channel 3 frequency 458000000
no channel 3 shutdown
channel 4 frequency 466000000
no channel 4 shutdown
channel 5 frequency 474000000
no channel 5 shutdown
channel 6 frequency 482000000
no channel 6 shutdown
channel 7 frequency 490000000
no channel 7 shutdown
channel 8 frequency 498000000
no channel 8 shutdown
channel 9 frequency 506000000
no channel 9 shutdown
channel 10 frequency 514000000
no channel 10 shutdown
channel 11 frequency 522000000
no channel 11 shutdown
channel 12 frequency 530000000
no channel 12 shutdown
channel 13 frequency 538000000
no channel 13 shutdown
channel 14 frequency 546000000
no channel 14 shutdown
channel 15 frequency 554000000
no channel 15 shutdown
channel 16 frequency 562000000
no channel 16 shutdown
channel 17 frequency 570000000
no channel 17 shutdown
channel 18 frequency 578000000
no channel 18 shutdown
channel 19 frequency 586000000
no channel 19 shutdown
channel 20 frequency 594000000
no channel 20 shutdown
channel 21 frequency 602000000
no channel 21 shutdown
channel 22 frequency 610000000
no channel 22 shutdown
channel 23 frequency 618000000
no channel 23 shutdown
channel 24 frequency 626000000
no channel 24 shutdown
channel 25 frequency 634000000
channel 25 shutdown
channel 26 frequency 642000000
channel 26 shutdown
channel 27 frequency 650000000
channel 27 shutdown
channel 28 frequency 658000000
channel 28 shutdown
channel 29 frequency 666000000
channel 29 shutdown
channel 30 frequency 674000000
no channel 30 shutdown
channel 31 frequency 682000000
channel 31 shutdown
channel 32 shutdown
channel 33 shutdown
channel 34 shutdown
channel 35 shutdown
channel 36 shutdown
channel 37 shutdown
channel 38 shutdown
channel 39 shutdown
channel 40 shutdown
channel 41 shutdown
channel 42 shutdown
channel 43 shutdown
channel 44 shutdown
channel 45 shutdown
channel 46 shutdown
channel 47 shutdown
no shutdown
!

kwesibrunee
What is your Annex Setting?

What is your Annex Setting? You can check by running show running-config verbose. The default is not set so it is possible you don't have one set, in which case you should set it.

since your channels are spaced 8 MHz apart I assume your in Europe, and you should be using Annex A, if your set to Annex B (North America) which is likely, the CMTS thinks you don't have contiguous channels, since it is expecting them to be 6 MHz apart with Annex B and it only allows so many non-contiguous blocks.

kdavid
Great! Look ok after set it

Great! Look ok after set it to ANEX A! Thank you very much.

kdavid
Upstream fine tuning

Hi,

i have a working solution of casa c100 with mikrotik in my lab.

Compared with cinese mini cmts i cant see how to setup an Upstream modulation, fec etc.

At this time there is my config of upstream channel.
I just dont understand what means logical channel 0 and 1.
For what are used minislots?
Is it needed to use preeqalisation?
Spectrum rules?
For what is used ingess-cancellation and how it works?

I also dont know what means lofical channel profile and how to set it.
I have now latency aroud 15ms what is quite much. Is there any way to have better latency?

interface upstream 1/0.0
frequency 40000000
channel-width 3200000
power-level 10
logical-channel 0 profile 3
logical-channel 0 minislot 2
no logical-channel 0 shutdown
logical-channel 1 profile 2
logical-channel 1 minislot 2
no logical-channel 1 shutdown
no shutdown

interface upstream 1/0.1
frequency 43200000
channel-width 3200000
power-level 10
logical-channel 0 profile 3
logical-channel 0 minislot 2
no logical-channel 0 shutdown
logical-channel 1 profile 2
logical-channel 1 minislot 2
no logical-channel 1 shutdown
no shutdown

interface upstream 1/0.2
frequency 46400000
channel-width 3200000
power-level 10
logical-channel 0 profile 3
logical-channel 0 minislot 2
no logical-channel 0 shutdown
logical-channel 1 profile 2
logical-channel 1 minislot 2
no logical-channel 1 shutdown
no shutdown

interface upstream 1/0.3
frequency 49600000
channel-width 3200000
power-level 10
logical-channel 0 profile 3
logical-channel 0 minislot 2
no logical-channel 0 shutdown
logical-channel 1 profile 2
logical-channel 1 minislot 2
no logical-channel 1 shutdown
no shutdown

Thank you veeeeery much!

dave

kwesibrunee
I would not worry about

I would not worry about logical channels just yet, however, you should no shut logical-channel 0, and shutdown logical-channel 1. Logical Channels and spectrum rules are a Casa Specific feature that allow you to run two different channels in the same spectrum, usually one with a larger channel-width and or different modulation. It is designed so that if you have modems with issues (SNR, Power) you can direct them to the logical channel with lower modulation and smaller channel width on an individual modem basis rather than change the modulation or channel width of all modems. Spectrum rules control when to move a particular modem.

Logical channel 0 profile refers to the modulation profile to assign the channel, if you run show modulation-profile you can see the built-in rules 1-5. Typically most operators use 2 and/or 3. You can also set a secondary profile which the channel will change to if their is impairments. Profile 1 is QPSK, Profile 2 is 16Qam and profile 3 is 64Qam.

Minislots on an ATDMA channel refer to how long each upstream transmission lasts a minislot is 20 usecs, this setting controls how many minislots to allocate to a modem needing to transmit for each bandwidth allocation. A smaller number means that more minislots are available to all the modems, but at the expense of more DS/US traffic to allocate them.

Pre-Equalization is something you want turned on, pre-equalization is a technique the CMTS and CM use to monitor the upstream signal as it comes in and adjust it if there are impairments so that when the signal reaches the CMTS it is as ideal as possible given the RF conditions. This can improve the signal considerably when it hits the CMTS.

Ingress-Cancelation is also a feature you want turned on, if it detects certain kinds of Ingress it will filter this noise out of the signal the CMTS recieves.

your power-level should be 0, this is the target level that the CMTS will use to tell the modem to make power adjustments. Whatever number is hear is what the CMTS will target and tell the modems to either turn up or turn down to hit that number. If you need attenuation it is better to do it with pads than with this setting.

I assume you mean the latency from CMTS -> CM, 10-15 is the normal range.

Here is a very typical Upstream config for 6.4 MHz wide and 64Qam (Profile 3)

interface upstream 1/0.0
description "MG Nodes 1,11"
frequency 36800000
channel-width 6400000
no fast-carrier-offset
power-adjustment continue 6
power-adjustment threshold 1
map-advance dynamic 400
no rate-limit
ingress-cancellation 100
partial-service fec-threshold 1.0
partial-service snr-threshold 0
no small-signal-compensation
pre-equalization extended-taps
logical-channel 0 profile 3
logical-channel 0 minislot 2
logical-channel 0 data-backoff automatic
logical-channel 0 ranging-backoff 0 4
logical-channel 0 pre-equalization auto-reset 1440
logical-channel 0 pre-equalization fast-ranging 1
no logical-channel 0 post-equalization
logical-channel 0 power-adjust 0
logical-channel 0 ranging-priority 0x0
logical-channel 0 class-id 0x0
no logical-channel 0 shutdown
logical-channel 1 shutdown
shutdown

kdavid
Oh, thak you for your reply.

Oh, thak you for your reply. Wou... So much interesting things that isnt int minicmts....

I am very interested in dual logical channel...

So it means that i can have 6,4 MHz US channel with QAM16 (Profile 2) as main modulation, and if there will be some noisy part of the network for eg. behid bad amp, i can enable also logical channel 1 with profile 1 (QPSK) and 3.2 MHz channel to ansure suitable quality of service?

This sounds like a dream for me... almost incredible.

Dont you have pls som kind of manual for this part of configuration?

About latency.... on minicmts i can setup channel width, modulation and fec.

There are also low latency modulation profiles for QAM 16, 32 and 64.
With that profiles in 6.4 MHz i have around 4 ms latency (cpe to CMTS) and with 3.2 MHz i have 5-7 ms.
So switching to 15-18 ms will not be unnoticed with gamers....

And one interesting thing in minicmts was that the spectrum and the spectral scan was nicly visible - live.
Are there any possibilities also in casa cli?

Thank you
Dave

kwesibrunee
The dual logical channel is

The dual logical channel is not commonly used, and it works a little different than you said. Basically the spectrum rules control which logical channel a modem connects to, based on SNR, FEC etc... The info is in the manual, let me see if I can find an example config.

More commonly operators use the secondary profile, the way this works is, if the average SNR, on the channel, drops below a threshold it will switch the modulation of the channel to the secondary channel. I believe you can have 3 secondary profiles on an upstream.

You can create your own modulation profiles on a Casa but it is not simple, you could try copying the profile from the other CMTS, but your unlikely to get the same results as the RF components are different. I have found that the built in profiles work best but many people have used other profiles without issue.

The closest thing to spectrum / spectral scan on a Casa CLI is the
show spectrum upstream slot/port.channel
and
show spectrum upstream slot/port.channel raw

you can tweak the channel-width too and it is live but won't refresh on its own.

The Casa CMTS (with a new enough version 8.6.3.2 for 8x192 cards) supports the UTSC Upstream Triggered Spectrum Capture, which would allow it to work with the several vendors that support it, Viavi, zCorum etc... which have a Web based return monitoring solution.

In a forthcoming version of the Casa software, the C100G will support Low Latency Docsis which can support latency of less than 1 ms and is a standard, look for it sometime later this year.

kdavid
So how should I set up the

So how should I set up the upstream to use it in best way?

As i see Modulation profile 2 supports QPSK and QAM with different fec

modulation-profile 2
request tdma qpsk off 64 0 16 338 0 16 fixed on
initial tdma qpsk off 640 5 34 338 0 48 fixed on
station tdma qpsk off 384 5 34 338 0 48 fixed on
short tdma 16qam off 168 6 75 338 7 16 shortened on
long tdma 16qam off 192 8 220 338 0 16 shortened on

It means inside of 6.4 MHz channel the cmts can handle all there 5 profiles in the same time?
So if i will use only 1 logical channel it will be anough to use unly this profile and nothing else?

As i see Profile 4 is using much more scale of modulations. What do you think about it?

You also wrote that it is possible to combine modulations with differend channel width on the same rf port. So that is what i am interested in.

About low latency docsis, you mean it probably only for Docsis 3.1 right? I dont heard about low latency docsis on D3.0 standard... but if yes it will be awesome.

kwesibrunee
In the modulation profile

In the modulation profile each line represents a different type of upstream traffic:
request -- Bandwidth Request
initial -- Initial Ranging
station -- Station Maintenance
short/long -- Used to actually transfer data upstream using TDMA (short is for small, bandwidth wise transmissions, long for full, bandwidth wise transmissions)
a-short/a-long -- same as short/long but uses ATDMA

Looking at the built in mod profiles
1 -- TDMA QPSK for customer data
2 -- TDMA 16qam for customer data
3 -- ATDMA 64qam for customer data
4 -- Mixed TDMA 16 QAM / ATDMA 64qam for customer data
5 -- SCDMA 128qam -- for Customer data SCDMA is not commonly used.

They all use QPSK for request/initial/station

The way you handle multiple profiles for an upstream channel is like so:

interface upstream 0/0.0
logical-channel 0 profile 3 secondary-profile 2

Then you use spectrum rules to control when the channel changes between the profiles

spectrum rule 1
channel-width 6400000 800000
action modulation channel-width
correctable-fec threshold 3
uncorrectable-fec threshold 1
profile 3 snr-threshold 280

interface upstream 1/0
spectrum-rule 1
logical-channel 0 profile 3 secondary-profile 2

What this does is allows the CMTS to narrow up the channel width and/or change profiles based on correctable/uncorrectable errors and will only use Profile 3 if the average SNR for the channel is at 28 dB otherwise it will use profile 2

You can have multiple secondary profiles, but would need to add a profile x snr-threshold for all but the lowest modulation one.

kdavid
OK so if i understand your

OK so if i understand your spectrum rule it will handel modems with lower SNR than 28 dBm and switch this bad modems to Profile 2 and changes channel width to 0.8 MHz? On the same physical ports coexist with 6,4 MHz channels? Really mindblowing.

I am really starting that i bought casa and not an older cisco ubr.

Is the any way to see which profile is modem using?

I tryed to add secondary profile and i have this error:
Secondary modulation profile 2 is not compatible with the primary profile 3

So probably i need to answer just a few last questions to put the beast into production environment.

As we discosed in the begining, the casa doesnt support vlans. I want to replace my several stand alone minicmtses. Each minicmts is for different village and each have its own mikrotik router with different networks.

If i am right, in thinking of casa i just need to create for each vilalge diferent:
interface docsis-mac
service group
interface ip-bundle (that wil use IP as default GW from mikrotis that are prerouted)

and asign RF ports to docsis macs and service groups....?

Is it ok?

It seems that it can be fast replacement for chinese minicmts.
kwesibrunee will you be able to helps me to debug it in the begining pls? I dont want you sevice for free, i just needs to be sure that everything will be ok.
Thank you
dave

kwesibrunee
That particular Spectrum Rule

That particular Spectrum Rule changes the whole channel not one specific modem, I could not find an example of a spectrum rule that used the cm-hop method, the one that changes a modem from one logical channel to the other, but it is documented in the RF guide.

Secondary profile 2 is not compatible with 3 because one is a TDMA profile and the other is a ATDMA profile, you would need to make a new profile that looked something like this

modulation-profile 102
request atdma qpsk off 64 0 16 338 0 16 fixed on 1 1536 qpsk0
initial atdma qpsk off 640 5 34 338 0 48 fixed on 1 1536 qpsk0
station atdma qpsk off 384 5 34 338 0 48 fixed on 1 1536 qpsk0
a-short atdma 16qam off 104 12 75 338 6 16 shortened on 1 1536 qpsk1
a-long atdma 16qam off 104 16 220 338 0 16 shortened on 1 1536 qpsk1

then use 102 as your secondary profile.

A more likely scenario for your interconnecting would be

Have 1 ip-bundle for all villages
1 or more Docsis Macs per village (this allows you to grow in each village as demand increases, you can physically split the RF and then create a new docsis mac for the new RF) all docsis macs use same ip-bundle
1-2+ Service groups for each docsis mac (depending on if your combining 1 or 2 (or more) Upstreams together, you need a service group for every distinct set of Upstreams in a docsis macs)
assign RF ports (US and DS) to both service group and docsis-mac
Add descriptions to your Docsis Macs to differentiate them that match the qam descriptions

you could do a separate ip-bundle for each village, but probably overkill and won't get you much advantage. Only advantage I can think of is, if you had an ip-bundle per area you could differentiate areas by modem ip, but you can do the same thing with docsis-macs / service groups / descriptions and it is a lot less work.

In this scenario the CMTS is your (edge) router and you probably don't need the microtik at all.... The C100G is a far more powerful router too.

hit me up via email on the help jasonp at snmpstack dot com
Depending on when it is, be glad to help, but going to be quite busy 3 of next 5 weeks.

kdavid
In first step i want to

In first step i want to miggrate only cmts, not routers. Becouse we are wunning CGNAT, so by default customers doesnt have public ips.
After migration CMTS to casa the next will be to migration from Mikrotik to Cisco ASR platform.

That you have only 1 ip-bundle is i think becouse you have 1 router for all villages, so in casa you have only 1 default GW.
But if i am right, i will need to set ip multiple VRFs to handle multiple gateways for each mikrotik router becouse in default all ip bundles will use the same one default gateway value what is not ok....

Or is possible to use multible default gateways for each IP bundle without VRF?
Or the best way for this is to use multiple VRF?
And if VRF what is the best way to configure VRF. I never done it before :(

About multiple Upstream profiles pleae tell me what is the best way to do it?
Use a multiple profile with sectrum rules that will switch and degrade whole spectrum?
Or coesxist 2 different profiles in same spectrum that will afect only bad modems. I am wondering if it is possible.

kwesibrunee
IP Bundles are not VRFs, casa

IP Bundles are not VRFs, casa can do both, but they are different things.

IP Bundle just joins CM and CPE ips into one large subnet, with ability to send DHCP requests to a specific DHCP helper address. They use the global routing table.

VRF setup a separate routing table, you can assign a VRF to an IP bundle to have a separate routing table for each IP bundle, but that is not the default.

It is hard to say, but from what you describe, you may need an ip-bundle for each village, but probably not a VRF.

if a route statement like this will suffice

ip route 192.168.0.0 255.255.0.0 172.16.0.1

you don't need a VRF,

if you need a route statement like this:

ip route 0.0.0.0 0.0.0.0 172.16.0.1

for each IP bundle then you need a VRF.

Both Spectrum Rule types work, but this one is much more widely deployed

Use a multiple profile with sectrum rules that will switch and degrade whole spectrum?

As such your much less likely to run into issues with this setup than the other.

kdavid
Im my case we have each ip

Im my case we have each ip bundle handled with separate physical router.

So each source range from IP bundle with destination 0.0.0.0/0 need to have as nexthop the IP of different mikrotik router.

But i am not able to create this kind of routes.

I am able to create a route only like this:
ip route 0.0.0.0/0 10.0.0.1 1

here are all possibilities:

CASA-C100G(config)#ip route 0.0.0.0/0
nexthop address A.B.C.D
gige gige
ip-bundle ip bundle
loopback loopback
null0 null interface (black hole)
trunk trunk
tunnel tunnel
video video interface
vlan vlan
xgige xgige
CASA-C100G(config)#ip route 0.0.0.0/0 ip-bundle 1

<1-255> distance (default : 1)
description description of the route
tag Set tag for this route

So there is not possible to combine or add an source range from ip bundles to have multiple GW (nexthops)
Maybe i am not right ...

For eg:

IP bundle 1 for village 1 :

interface ip-bundle 1

ip address 192.168.0.1 255.255.255.0
ip address 192.168.1.1 255.255.255.0 secondary
cable helper-address 10.0.0.1 global

IP budle 2 for village 2:

interface ip-bundle 2

ip address 192.168.10.1 255.255.255.0
ip address 192.168.100.1 255.255.255.0 secondary
cable helper-address 10.0.100.1 global

IP address of mikrotik router for village 1 will be 10.0.0.1
IP address of mikrotik router for village 2 will be 10.0.100.1

Or can the Ips of routers be on same subnet? like:

IP address off rouer for village 1 will be 10.0.0.1
IP adress of router for village 2 will be 10.0.0.2

And the casa will have an ip 10.0.0.254 on XGCE int?

But how to handle multiple gateway for each IP-Bundle :(

kdavid
OK, as i see there is not

OK, as i see there is not possible to have multiple vrf on xgige int :(

Any idea how to solve multiple GW with VRF pls?

Thank you

kwesibrunee
After creating the VRF

After creating the VRF
ip vrf VRF_NAME

add your default route
ip route vrf VRF_NAME 0.0.0.0/0 192.168.0.1

you would then apply the VRF to the ip-bundle

interface ip-bundle 1
ip vrf forwarding VRF_NAME

Rinse and repeat for any other IP-Bundle/VRF combo needed.

kdavid
I have done it this way, but

I have done it this way, but it worked only when i also enables forwad vrf on xgige interface too.

So it is not needed to enable vrf forward on uplink interface?
Can i have only 1 IP on uplink int or i need have multiple secondary IPs with different subnets?

kwesibrunee
That would really depend on

That would really depend on your setup,

VRFs are not common on CMTSes here in the US where I live, so not much experience with them on a CMTS.

I would imagine you would need an uplink per VRF on the CMTS, If your trying to put more than one VRF per interface, why do you need VRF at all?

VRFs seem to be super overkill for something as simple as a CMTS with 5 SGs, Most Operators (US anyways) just send all the traffic to an upstream router where the upstream router handles routing.

I suspect what your trying to do is aggregate all of your RF in one central place, but then send it back out IP to the upstream router in the remote area. While that will work, that seems a bit extreme, it would make more sense to aggregate your IP to a central place/link then VRFs would not be necessary at all.

kdavid
Ok, i have it done by

Ok, i have it done by multiple uplinks - vlans .. it looks it works OK. Bit overkill but each docsis mac group is isolated.
I will test it and let you know.

Thanx a lot!

I need to solve only upstream logial channel for secon profile only for bad modems... didnt you find any config about it pls?
Thanx

dave

kwesibrunee
I did find a config but it

I did find a config but it was from a way old version 6.x .... no guarantees it works on 7.2.5.4, all the commands are present in 7.2.5.4, but their could be additional commands needed.

hop period 30
cable monitor-period 30

spectrum rule 2
cm-hop
correctable-fec threshold 50
uncorrectable-fec threshold 10

interface upstream 1/0.0
spectrum-rule 2
frequency 20000000
channel-width 6400000
logical-channel 0 channel-width 6400000
logical-channel 0 profile 3
logical-channel 0 minislot 4
logical-channel 0 pre-equalization
no logical-channel 0 shutdown
logical-channel 1 channel-width 800000
logical-channel 1 profile 12
logical-channel 1 minislot 16
logical-channel 1 pre-equalization
no logical-channel 1 shutdown
no shutdown

note: both Logical Channels must be in SG and Docsis mac and each Logical Channel uses an upstream license.
you can use
show cm-hop log

to see when modems move from one to the other.

kdavid
Ok thank you very much! I

Ok thank you very much! I will play with it and I let you know.

But... as i sayd i am new in casa envoronment... so i am a bit supprised about license.
I tryed show license or some cisco similar commands but found nothing about license usage in my box....

You mean if i can have 8 upstream channels per RF port then i can have now only 4 for logical channel 0 and 4 for logcal channel 1 and they will share the same freq?

Is it still possible to combine secondary profile with logical channel 0 ?

Or only 1 combination?

kdavid
Can you pls check me my

Can you pls check me my config?
I an mot sure if this spectrum rule can handle what i want.

Logical channel with profile 3, secondary profile multiple frofile
And also logical channel 1 as worst case scenario.
My config:

spectrum rule 1
cm-hop
channel-width 6400000 1600000
action modulation
back-hop-limit 3 2
correctable-fec threshold 15
uncorrectable-fec threshold 2
profile 3 snr-threshold 300
profile 101 snr-threshold 260
profile 102 snr-threshold 280

interface upstream 1/0.0
spectrum-rule 1
frequency 41000000
channel-width 800000
power-level 10
power-adjustment continue 6
map-advance dynamic 400
no rate-limit
ingress-cancellation 100
pre-equalization extended-taps
logical-channel 0 profile 3 secondary-profile 102,101
logical-channel 0 minislot 16
logical-channel 0 pre-equalization auto-reset
no logical-channel 0 shutdown
logical-channel 1 profile 1
logical-channel 1 minislot 8
no logical-channel 1 shutdown
no shutdown

modulation-profile 101
request atdma qpsk off 64 0 16 338 0 16 fixed on 1 1536 qpsk0
initial atdma qpsk off 640 5 34 338 0 48 fixed on 1 1536 qpsk0
station atdma qpsk off 384 5 34 338 0 48 fixed on 1 1536 qpsk0
a-short atdma qpsk off 84 6 75 338 13 16 shortened on 1 1536 qpsk0
a-long atdma qpsk off 96 8 220 338 0 16 shortened on 1 1536 qpsk0

modulation-profile 102
request atdma qpsk off 64 0 16 338 0 16 fixed on 1 1536 qpsk0
initial atdma qpsk off 640 5 34 338 0 48 fixed on 1 1536 qpsk0
station atdma qpsk off 384 5 34 338 0 48 fixed on 1 1536 qpsk0
a-short atdma 16qam off 104 12 75 338 6 16 shortened on 1 1536 qpsk1
a-long atdma 16qam off 104 16 220 338 0 16 shortened on 1 1536 qpsk1

cmcaldas
ofdma

Hi kwesibrunee
curious if you have one for ofdma. I've tried different configs and it's working, just wanted to see if anyone has a different config that's working good in the field. below is my current config on an hfc plant.
ofdma minislot-cfg 1
subcarrier-group-minislot 1 43000000 60000000 modulation 256qam pilot-pattern 8
subcarrier-group-minislot 2 61000000 84000000 modulation 512qam pilot-pattern 8

ofdma iuc-profile 1
fine-ranging-iuc 32 10000000 offset 100
initial-ranging-iuc 64 10000000 offset 237
data-iuc 5 modulation 256qam pilot-pattern 4
data-iuc 6 modulation 512qam pilot-pattern 4
data-iuc 9 modulation 128qam pilot-pattern 4
data-iuc 13 modulation 64qam pilot-pattern 4

interface ofdma 10/1.0
description "node_1 ofdma"
lower-freq 42000000 upper-freq 85000000
ranging-backoff 2 8
map-advance dynamic 200
no voice-bw-reserve
power-adjust continue 4
pre-equalization
multiple-iuc
multiple-iuc max-retry 3
multiple-iuc err-threshold 100
dynamic-iuc null-state-timeout 0
rolloff-period 64
iuc-profile 1
no shutdown

kwesibrunee
CMCaldus,

CMCaldus,

OFDMA is a different beast for sure....

Would need answers to the following questions to give a full response:
Are you intending to do TaFDM?
if so, what is the overlapping need all ATDMA configs?
If not, need the closest (frequency wise) ATDMA Config to make sure there is enough separation between the ATDMA and OFDMA channel.

You have a minislot-cfg listed, but it is not applied to any IUC in the IUC profile? Is this intentional? If Not what IUC(s) should it be applied to?

Could you get a verbose output of your ofdma channel? some defaults change with software version.

What software version are you using?

That being said
here is what I would recommend based on what I know

1) Assuming you want your channel to be greater than 42 MHz and be less than 85 MHz, OFDMA lower-freq == start frequency of lowest data sub carrier, upper-freq == end frequency of last data sub carrier, so with a sub carrier spacing of 50 KHz, this makes the first data subcarrier 42025000-42075000 with a center frequency of 42050000 MHz. In an OFDMA channel all of the center frequencies of the subcarriers have to be divisible by the subcarrier spacing, if you don't configure it that way, the CMTS will silently change it for you, and probably affect your minislot boundaries resulting in unusable sub carriers. So utilizing our start frequency of 42025000 you can only fit 107 x 400 KHz fully between there and 85 MHz meaning the last usable data subcarrier would be 84775000-84825000 with a center frequency of 84800000.

If you don't specifically configure it that way, the CMTS will do what you say and it will result in 3 unusable subcarriers from 84825000-84975000 which won't affect data transfer, but will create a weird spike on ICFR on a meter that will make field techs scratch their heads.

2) IUC 13 is your most important IUC, this is the IUC the modem uses to communicate to CMTS for things like DBCs, regardless if it is using another IUC as primary, this is how your modem switches from one IUC to another, so if your IUC 13 is not 100% reliable you will end up with an unreliable OFDMA channel. I.e. you have an impairment in your channel at a specific minislot, and say the MER threshold is below your IUC 13 reliable threshold, if the modem attempts to use that minislot to communicate the DBC to move to a different IUC it is likely to fail and cause a myriad of issues, Partial Service, degraded service etc... I always recommend you use lowest modulation, highest pilot for IUC 13 for most reliable transmission using that IUC. If your plant is even marginally well maintained most modems will not use that as their primary IUC, and if they do, well you have other problems to fix before OFDMA will be successful

ofdma iuc-profile 1
! defaults for fine and initial ranging not likely to have an effect on channel
fine-ranging-iuc 32 8000000
initial-ranging-iuc 32 8000000
! may need to play with Pilot pattern, but you should not need 4 on every IUC, just on ones where reliable communication is not likely
data-iuc 5 modulation 1024qam pilot-pattern 1
data-iuc 6 modulation 512qam pilot-pattern 2
data-iuc 9 modulation 128qam pilot-pattern 2
data-iuc 12 modulation 64qam pilot-pattern 3
data-iuc 13 modulation qpsk pilot-pattern 4

ofdma interface 0/0.0
! when you put lower-freq 42000000 upper-freq 85000000 ultimately this is what the CMTS is setting behind the scenes.
lower-freq 42025000 upper-freq 84825000
! There are two different guardbands depending on your version use this one if at all possible
regular guardband
iuc-profile 1
! on an OFDMA channel pre-equalization does not always work (especially in case of random noise) this allows the CMTS to turn on/off pre-eq if it will help
pre-equalization auto-decision
multiple-iuc
! the default interval (in 10sec increments) is 6 or in other words a minute, if your only using Multiple-IUC probably want it checking as often as possible (10 secs)
multiple-iuc interval 1
multiple-iuc max-retry 3
! I would keep the err-threshold the default 20 (.02 %)
multiple-iuc err-threshold 20
sc-spacing 50
! may want to play with cyclic-prefix and rolloff periods defaults are cp 256 rp 128
cyclic-prefix 256
rolloff-period 64
symbols-per-frame 16
! power is measured differently on an OFDMA channel, assuming you have adjacent 6.4 MHz channel with power level 0, your ofdma power level should be -6, if it were 3.2 mhz wide it would be -3, 1.6 MHz wide it would be 0.
power -6
! Casa proprietary feature to move the ranging zone around if the CMTS detects an impairment at a certain location
dynamic-ranging-zone
no shutdown

cmcaldas
info

thanks for info, I'm lucky to have a lab and live system to work with. it's been more of trial and error to be honest.
7261 is the sw. I'll review and try some of the changes and circle back
Thank you

Log in or register to post comments